Issues with App Center in the EU Region.
Incident Report for Modo Labs, Inc.
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 16:56 EDT
Investigating
The issue is being investigated by an upstream provider.
Posted Sep 27, 2023 - 14:00 EDT
This incident affected: Modo App Center and Modo Authenticate.