Partial Outage affecting some applications

Incident Report for Modo Labs, Inc.

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 09:12 EDT

Monitoring

Our upstream provider is working on a fix and we are monitoring as we start to see some signs of recovery
Posted Jul 24, 2026 - 08:02 EDT

Identified

We have identified a networking issue with our upstream provider
Posted Jul 24, 2026 - 07:51 EDT

Investigating

We are currently investigating this issue.
Posted Jul 24, 2026 - 07:51 EDT
This incident affected: Modo Application Servers, Modo App Center, Modo Analyze, Modo Communicate, Modo Authenticate, and Modo Space Booking.